Recherche

Le Blogue

Bulletin électronique

Inscrivez-vous pour recevoir par courriel les derniers articles du blogue.

J'ai lu et accepte la Politique de confidentialité de ce site

Informations

Suivez-moi !

Suivre sur Twitter Suivre sur Facebook Suivre sur Linkedin Suivre sur YouTube S'abonner au fil RSS

Copyright 2019 © dominicdesbiens.com
Tous droits réservés

Design Web basé sur une création de
Olivier Leblanc

Comment résoudre le problème de connexion MySQL dans WordPress après avoir activé PHP 7.2

Publié le 16 janvier 2019 | Internet | 0 commentaire

Aujourd'hui, j'ai lu un article selon lequel WordPress va afficher des notifications dans l'interface d'administration de notre blogue dans le cas où celui-ci est hébergé sur un serveur utilisant une version de PHP antérieure à 5.6. J'ai passé la mienne de la 7.0 à la 7.2. Or, suite à cette manipulation, je me suis retrouvé avec un message d'erreur sur mon blogue lié à MySQL (base de données). Si cela vous arrive, voici la solution toute simple.

La version 5.6 de PHP, langage de programmation Web très populaire et utilisé par des millions de sites, dont ceux fonctionnant avec WordPress, n'est plus supporté par l'équipe de développement de PHP depuis le 1er janvier 2019. Il n'y aura plus de mises à jour pour cette version devenue obsolète.

Concrètement, cela veut donc dire que les sites Web fonctionnant avec cette version de PHP ou les versions antérieures à celle-ci seront plus vulnérables au piratage informatique (les failles de sécurité ne seront plus corrigées).

Je vous recommande fortement de demander à votre hébergeur Web d'activer la plus récente version « stable » de PHP, du moins si votre site Web fonctionne avec une plateforme régulièrement mise à jour comme WordPress qui prend en charge les changements liés aux nouvelles versions du langage de programmation.

D'ailleurs, certains fournisseurs d'hébergement Web le font automatiquement pour leurs clients. Selon votre fournisseur, vous avez aussi peut-être, voire sûrement, la possibilité de changer vous-même la version de PHP sur votre hébergement. Chez Funio où mon blogue est hébergé depuis très longtemps, je peux changer la version de PHP dans la page d'administration de « cPanel ».

Version PHP dans cPanel

Outre l'activation de la version stable la plus récente de PHP, je recommande aussi d'installer les récentes mises à jour de WordPress si vous utilisez cette plateforme. Récemment, j'ai passé mon blogue à la version 5 de WordPress (je suis en train de convertir tous les articles de mon blogue pour prendre en charge le nouvel éditeur Gutenberg).

Vous avez activé la version 7.2 de PHP et votre blogue WordPress est en problème ? Solution...

Suite au passage à la version 7.2 de PHP, mon site Web a affiché le message d'erreur suivant :

« Votre installation de PHP ne dispose pas de MySQL. Extension requise pour WordPress ».

La solution à cette erreur est très simple (pour autant que le changement ait été effectué dans cPanel). Elle devrait fonctionner aussi avec d'autres panneaux de configuration, mais je ne l'ai pas testée sur ceux-ci.

Dans cPanel, lorsque vous activez une version de PHP, le panneau de configuration propose diverses options du langage de programmation auxquelles vous pouvez donner ou pas des autorisations. En général, il est préférable de ne pas toucher à ces options à moins de savoir ce que l'on fait (certaines options peuvent entraîner des bogues inattendus sur son site Internet).

Dans le cas de l'activation de PHP 7.2, il faut cocher la case correspondant à l'option « mysqli » et cliquer sur le bouton « Enregistrer » pour appliquer la modification. Et voilà, il suffit d'actualiser la page de son site Internet dans le navigateur pour constater qu'il est à nouveau opérationnel.

Autorisations de mysqli dans cPanel

Publicité

Partagez cet article !

Récemment dans « Internet »

Sujets connexes

Laisser un commentaire

Nom *

Adresse de courriel *

Site Web

Commentaire *

Merci de commenter cet article. Tous les commentaires publiés sur ce blogue sont modérés et soumis à mon approbation. Votre adresse de courriel est requise, mais ne sera pas visible publiquement.

Consultez la politique de confidentialité de ce site Web pour en savoir plus sur la collecte, la conservation et l'utilisation de vos données personnelles.

Liens vers cet article :

  1. […] Aujourd’hui, j’ai lu un article selon lequel WordPress va afficher des notifications dans l’interface d’administration de notre blogue dans le cas où celui-ci est hébergé sur un serveur utilisant une version de PHP antérieure à 5.6. J’ai passé la mienne de la 7.0 à la 7.2. Or, suite à cette manipulation, je me suis retrouvé […] → Lire la suite […]